← HeatShield Docs

WordPress Hosting Requirements

To use the WordPress Firewall, your server must have the HeatShield agent installed. The HeatShield agent is required because HeatShield uses an extremely fast, enterprise-grade Web Application Firewall engine, ModSecurity, that cannot be run within WordPress.

Installing the HeatShield Agent

If you have your own server, you can install the HeatShield agent if your server meets the requirements.

Operating System Ubuntu LTS 14.04, 16.04, 18.04 or 20.04
Architecture 64-bit
Virtualization Any

If you use managed hosting, please contact your hosting company to see if they support HeatShield.

Advanced security for your WordPress sites